Resultados 1 al 5 de 5

Tema: Raspbian+minidlna=Conflictos con libperl

  1. #1
    Gordo en rehabilitación
    Avatar de tokugawa
    Fecha de ingreso
    09 Sep, 06
    Ubicación
    -37.459999,-72.36
    Mensajes
    8,006

    Raspbian+minidlna=Conflictos con libperl

    Eso no mas, hace rato que no webeo en linux asi que ya ni me acuerdo sobre como arreglar este tipo de confilctos, hice un upgrade/update antes de comenzar a instlar, luego ejecute
    sudo apt-get install minidlna
    y obtengo

    Los siguientes paquetes tienen dependencias incumplidas:
    perl : Depende: perl-modules (>= 5.14.2-15+rpi1) pero 5.14.2-12+rpi1 va a ser instalado
    E: Dependencias incumplidas. Intente «apt-get -f install» sin paquetes (o especifique una solución).

    ejecutando la orde nde apt-get -f install el mensaje es le mismo XD
    Sent from mi ipaj using fapfap

    http://geoturismo.cl http://farmacias.deturno.net/mapa
    busco chamba

    Warning: A toda la comunidad Troll, las pescadas que escriba en offtopic son sólo eso , y no son validas como argumento en una discusión de Actualidad y/u otro foro donde las pescadas no tengan cabida

  2. #2
    ....................
    Avatar de oscagriff
    Fecha de ingreso
    21 Dec, 06
    Ubicación
    Santiago/Chile
    Mensajes
    7,601

    Re: Raspbian+minidlna=Conflictos con libperl

    Como dice en el error, el problema es que el paquete perl-modules que se instala es un poco mas antiguo que el que requiere el paquete minidlna, por eso el problema.

    La opcion, creo, es instalar alguna version mas nueva del paquete "perl-modules", no se si una version testing o inestable (si quieres correr el riesgo) y despues de eso instalar el paquete "minidlna".

  3. #3
    Guru
    Avatar de Cosme
    Fecha de ingreso
    27 Feb, 05
    Ubicación
    Santiago
    Mensajes
    9,138

    Re: Raspbian+minidlna=Conflictos con libperl

    see, eso huele a zorra de dependencias

    le hiciste un upgrade?



  4. #4
    Avanzado
    Fecha de ingreso
    16 Mar, 12
    Mensajes
    1,120

    Re: Raspbian+minidlna=Conflictos con libperl

    busca en packages.debian.org la version del paquete que necesitas. Si no esta ahí prueba en snapshot.debian.org/. La última es la pagina donde esta el historico de los paquetes de debian, si alguna vez salio lo que necesitas como paquete oficial esta ahi si o si.

  5. #5
    Gordo en rehabilitación
    Avatar de tokugawa
    Fecha de ingreso
    09 Sep, 06
    Ubicación
    -37.459999,-72.36
    Mensajes
    8,006

    Re: Raspbian+minidlna=Conflictos con libperl

    mas ratito vere lo de debian gracias, ojo que es una version para ARM

    ---------- Post added at 03:11 ---------- Previous post was at 19:56 ----------

    sudo apt-get -f install
    Leyendo lista de paquetes... Hecho
    Creando árbol de dependencias
    Leyendo la información de estado... Hecho
    Corrigiendo dependencias... Listo
    Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
    python-cairo python-glade2 python-gtk2
    Use 'apt-get autoremove' to remove them.
    Se instalarán los siguientes paquetes extras:
    libperl5.14 perl-modules
    Se actualizarán los siguientes paquetes:
    libperl5.14 perl-modules
    2 actualizados, 0 se instalarán, 0 para eliminar y 229 no actualizados.
    3 no instalados del todo o eliminados.
    Se necesita descargar 0 B/3.436 kB de archivos.
    Se utilizarán 1.024 B de espacio de disco adicional después de esta operación.
    ¿Desea continuar [S/n]? s
    s
    (Leyendo la base de datos ... 93085 ficheros o directorios instalados actualmente.)
    Preparando para reemplazar libperl5.14 5.14.2-12+rpi1 (usando .../libperl5.14_5.14.2-15+rpi1_armhf.deb) ...
    Desempaquetando el reemplazo de libperl5.14 ...
    dpkg: error processing /var/cache/apt/archives/libperl5.14_5.14.2-15+rpi1_armhf.deb (--unpack):
    no se puede instalar el (supuestamente) nuevo fichero de información `/var/lib/dpkg/tmp.ci/md5sums': Error de entrada/salida
    Se encontraron errores al procesar:
    /var/cache/apt/archives/libperl5.14_5.14.2-15+rpi1_armhf.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    lorem ipsum dolor asimet

    ---------- Post added at 03:14 ---------- Previous post was at 03:11 ----------

    sudo apt-get -f install
    Leyendo lista de paquetes... Hecho
    Creando árbol de dependencias
    Leyendo la información de estado... Hecho
    Corrigiendo dependencias... Listo
    Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
    python-cairo python-glade2 python-gtk2
    Use 'apt-get autoremove' to remove them.
    Se instalarán los siguientes paquetes extras:
    libperl5.14 perl-modules
    Se actualizarán los siguientes paquetes:
    libperl5.14 perl-modules
    2 actualizados, 0 se instalarán, 0 para eliminar y 229 no actualizados.
    3 no instalados del todo o eliminados.
    Se necesita descargar 0 B/3.436 kB de archivos.
    Se utilizarán 1.024 B de espacio de disco adicional después de esta operación.
    ¿Desea continuar [S/n]? s
    s
    (Leyendo la base de datos ... 93085 ficheros o directorios instalados actualmente.)
    Preparando para reemplazar libperl5.14 5.14.2-12+rpi1 (usando .../libperl5.14_5.14.2-15+rpi1_armhf.deb) ...
    Desempaquetando el reemplazo de libperl5.14 ...
    dpkg: error processing /var/cache/apt/archives/libperl5.14_5.14.2-15+rpi1_armhf.deb (--unpack):
    no se puede instalar el (supuestamente) nuevo fichero de información `/var/lib/dpkg/tmp.ci/md5sums': Error de entrada/salida
    Se encontraron errores al procesar:
    /var/cache/apt/archives/libperl5.14_5.14.2-15+rpi1_armhf.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    lorem ipsum dolor asimet
    Sent from mi ipaj using fapfap

    http://geoturismo.cl http://farmacias.deturno.net/mapa
    busco chamba

    Warning: A toda la comunidad Troll, las pescadas que escriba en offtopic son sólo eso , y no son validas como argumento en una discusión de Actualidad y/u otro foro donde las pescadas no tengan cabida

Permisos de publicación

  • No puedes crear nuevos temas
  • No puedes responder temas
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •  
*